wall visibility

Question Modeling

Please tell me, I am completing the course Fundamentals of 3D Mesh Modeling in Blender . proceeded to create work. But can't turn on restricted viewing properly.

I turn it on "backface culling", but it does not turn off the front walls, but the rear ones. help me understand023-02-25 160948.png

  • Martin Bergwerf replied

    Hi Natalia,

    You should turn your Mesh 'inside out':

    In Edit Mode, select everything (shortcut A) and then ALT+N (Normals menu) > Flip.

    1 love
  • Natalia Tkachyk(TkachykN) replied

    thank you very much, sending rays of goodness ;)

    хороших вихідних)

  • Martin Bergwerf replied


  • Omar Domenech replied

    Yeah I can totally read that. 

    When enabling backface culling, it's by looking at the back of your face that things get transparent. The way you know which is the back of your face is by how your normals are pointing. You can turn on face orientation and where you see blue, things will be opaque, where you see red, things will get transparent. 

    face Orientation.png

    1 love
  • Natalia Tkachyk(TkachykN) replied

    Тhank you)

    • 🤘
  • Natalia Tkachyk(TkachykN) replied

    one more question. I did everything you wrote.


    I can't edit, they just became transparent. maybe that's right...

    but on cycles, the front walls still hide everything else, even though I unchecked the camera.111.pngуцуц.png

  • Natalia Tkachyk(TkachykN) replied

    looked again and only noticed that the front walls of the cube inside were also transparent. this night, I will have to search for answers to many questions ;)

    and this is just an introductory course on Mesh Modeling in Blender

  • Martin Bergwerf replied

    Hi Natalia,

    If you enable X-ray, you can select through the invisible walls (and Edit stuff).

    In Eevee, you can set Backface Culling in the Material Settings:


    In Cycles you can hack the Material like this:

    Viewing hack.png

    No need to understand this yet, but basically, when the Normals of a Face are turned away from the Camera, they use the Transparent Shader.

  • Natalia Tkachyk(TkachykN) replied

    I will try further with new information