Error: Failed to insert keys on F-Curve ...

posted to: Bouncing Ball


I'm having trouble inserting keyframes.

I'll include a screen recording so you can see what I did. I feel like the process should be fairly straight forward, yet I get this error** when trying to insert any keyframes in between the first and last. I can add each keyframe in succession, but it's more work to get the ball to move at a consistent speed that way. 

**Error: Failed to insert keys on F-Curve with path 'pose.bones["Body"].location[2]', ensure that it is not locked or sampled, and try removing F-Modifiers

I looked at the "Modifiers" tab in the Graph Editor properties, and it doesn't look like there are any F-curve modifiers. It also doesn't look like any channels are locked, though I'm not sure how to see if they are sampled. 

I'm starting from right before adding the first keyframe, and following along with the video. I have auto keying enabled, as well as "Available" as the active keying set.

Also, I realize I'm using 4.1 instead of 2.82. I feel like this process is very similar between these versions though, so I didn't see the need to use an older version of Blender. I like to do the tutorials on the most current version and make the necessary adjustments right away, so that I'm not building muscle memory that I'll have to change soon. This is the first time I've been unable to account for UI changes, which leads me to believe that's not the issue. 

1 love
  • Shay Spear(Spearshay) replied
    1 love
  • Martin Bergwerf replied

    Hi Shay,

     "I feel like this process is very similar between these versions though, so I didn't see the need to use an older version of Blender."

    Right, but we don't recommend using the Tutorial's Version for nothing...

    The shortcuts have changed a bit:

    1 love
  • Omar Domenech replied
    Blender changes too much so I wouldn't put all my chips into muscle memory. It's better to learn the concepts and you can do that in any Blender version, then adjusting to where things might be in any version of Blender is a piece of cake. As you learn more and more the versions things becomes transparent to you, in the mean time it's better to make things as less complicated as possible, and that is why I always do my practice and tutorial watching on the Blender version I see on the video.
    1 love
  • Dwayne Savage(dillenbata3) replied

    I feel like there is something with an addon, but here is something to try. In 3D Viewport, click Pose menu->animation->Clear Keyframes. Make sure to do Clear not delete. Then try doing the same thing. If you still get the error then maybe post a link to blend file. 

  • Wayne Dixon replied

    Hi Shay, 
    This looks normal to me.

    You are getting the error because the 'Available' keying set will only keyframe existing channels.
    I can see, however, in the autokey dropdown that you don't have "Only Active Keying Set" enabled.

    This is why it is adding the Y loc channel back.
    If you check that one on, it will work exactly like the tutorial.

    Keying has changed a little bit in 4.1 (as spikey mentioned) - where you don't get the popup menu when you hit "i" and don't have a keying set enabled.
    But none of the changes are show stoppers for the workflow shown in the tutorials.

    Hope that helps.

    2 loves
  • Shay Spear(Spearshay) replied

    Thanks guys!

    So I submitted the completed exercise, done in 2.82. I get the concept, I still can't seem to translate it to 4.1 though. I tried clearing the keyframes using the method suggest by Dwane. I have "only Active Keying Set" enabled, I disabled all mods except a couple basic stock ones, and I still get that error when trying to insert keyframes between other keyframes using either "I" or "K'. 

    "K" gives me a keying set options menu. When I click any of them, it doesn't give me an error, but it also doesn't apply any keyframes. 

    I tried this same process in a new file, as well as with the "bouncing ball" blend file from the course files, and the same thing happens in both. I'll include the video of the other basic animation. It's just a weird shape spinning. 

    So as much as I dislike not solving errors, no this is not a major holdup. It could be somewhat inconvenient for my animation workflow, but at the end of the day I can work around it. 

    1 love
  • Wayne Dixon replied

    Hi Shay,

    From looking at your video, Blender is doing exactly what you are telling it to.
    As previously mentioned the error comes from the 'Available' keying set not being able to set keys because there are no existing channels to keyframe. (ie - nothing is 'available')

    Pressing i over the viewport will key all available channels.
    Pressing i over the channel input boxes will key just those channels (not linked with the keying set option by design)
    And when you adjust 1 channel in the input box, it will keyframe the change you made on that channel (not linked with the keying set by design)

    If you want to key all the other channels as well - just press i over the viewport (after there are channels available) 

    The new keying set menu - the K key, will not key anything for you.  That is just an easier way to change the keying set.

    If you are wanting to do something different could you explain it a little more?  

    1 love
  • Shay Spear(Spearshay) replied

    I'm sorry I'm having such a hard time with this concept. 

    I'll post the bouncing ball video again. I'm using 4.1, just trying to do what you do in the video, where you make the starting and ending frames, then you insert the keyframes in between by dragging the playhead to the bouncing points and hitting "I". 

    I can make the starting and ending frames, then after dragging the playhead to the next point, and hitting "I" in the viewport, it says "failed to insert any keyframes", and then hitting "I" over the channel input boxes gives me the error message, but inputs a key for the Y channel, which I had deleted.

    It will insert keys when I adjust a single channel though. So does auto-keying not insert keys unless an actual transformation is made?

    Would it be helpful if I got a screen cast keys addon?

    Like I said, I feel like I get the concept. Completing the exercise using the same Blender version was no problem, of course. But I need to be able to translate that knowledge to the current version of Blender eventually, and I'm getting the same issue in both the starting file and a fresh file. 

    1 love
  • Wayne Dixon replied

    Oh that's really interesting Shay.
    Annoying for you yes - but interesting because you may have found a bug

    Thanks for this video because it is clearly showing the error and not the workaround you were using.

    Can I ask a few questions to help resolve this....

    • Does this happen when you open a fresh file and you do the same process with the default cube?
    • Is it possible for you to post that exact file (from the video) somewhere we can grab it. (like Dropbox etc)

    If the same thing happens on the default cube and this file for you, but not for us, then it's likely something to do with your setup.
    You can try resetting Blender back to the factory settings and seeing if that fixes the issue.  If you haven't changed many settings away from default or your not afraid of losing all your preferences, you can do that now.
    But if it's annoying to set it up the way you like, then wait until we have the same issue (or not).  Or you could download one of the latest builds and test it on that (with factory settings - don't import any preferences if Blender asks).  This will be a workaround as to not wipe out your settings on the current stable version if you don't need to.

    1 love
  • Martin Bergwerf replied

    At least Download 4.1.1, because a lot of bugs were fixed, compared to 4.1.0.

    And using Load Factory Settings is always a good idea, when troubleshooting. You won't lose anything, it isn't permanent.

    1 love
  • Dwayne Savage(dillenbata3) replied

    Good catch spikeyxxx. I was trying to reproduce the problem. I'm using 4.1.1. when I get home I'll try it with 4.1.0. 

  • Shay Spear(Spearshay) replied

    Ok awesome, thanks guys! I think we're getting somewhere....

    To answer your first question Wayne, yes it does the same thing with a fresh file, on the default cube. I reset back to factory settings and that actually seemed to resolve the issue. I was able to insert keyframes as expected. 

    I downloaded 4.1.1 after that, and kept my old user preferences, and I was getting the error messages again. So I then reset back to factory settings again in 4.1.1, and keyframe insertion works again. 

    So I think we've narrowed it down to something in my setup. Now I can at least work from zero and re-enable my add-ons one by one to see if any of them are the issue. I'll be sure to use this troubleshooting method in the future =)

    I could still post the Blend file if that would be helpful for any reason. 

    Thanks a ton for your patience and assistance!

    1 love
  • Wayne Dixon replied

    Hey Shay,
    Glad you narrowed down the issue.
    Posting the file won't help in this case as the issue is something specific with your machine.

    Maybe it's an add-on messing things up - maybe it's just something in your preferences that got messed up.
    Maybe it's because that pigeon looked at you weirdly the other day.  We may never know.

    But restarting with fresh preferences seems like a reasonable solution.
    You will *think* you have everything set up properly again, but then you will get a few days in and wonder why you can't do that thing you usually do and you'll scratch your head and finally remember... "Oh that's right, I changed that setting" or "I haven't enabled that add-on I usually use".

    But I'm really glad you got the problem solved. :)

    1 love